
Curaçao Help Index
This index contains all of the help topics available for Curaçao.    To select a topic, click 

on it with the mouse.    Topics are arranged according to the organization of the program.    
Use the scroll bar to see    entries that are not currently visible in the help window.    

For more information on how to use help, press F1 or choose Using Help from the Help 
menu.
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Introduction
The sterile insect release method (SIRM) of pest population supression consists of 

releasing large numbers of sterilized insects into the environment to reduce the probability
that members of a natural population of the same species will successfully reproduce.    
The practical feasibility of this method was first demonstrated by E. F. Knipling's 
eradication of the screwworm, Cochliomyia hominivorax, from the Caribbean island of 
Curaçao in 1955.

Selecting Run from the File Menu immediately upon program startup will reproduce the
simple mathematical model that Knipling (1979) presented to demonstrate that, in theory, 
the method can bring about the total eradication of a defined population in a small number
of generations.

The following assumptions are implicit in Knipling's simple model:
1. The initial population is 1 million insects, half male and half female, in a well-defined 

geographic area.
2. Both the native and released sterile insects are dispersed uniformly (no spatial 

variability and no migration).
3. Exactly 9 sterile males are released for each native male.
4. Sterile males are equally competitive as native males for mates.
5. For every female, 5 female progeny survive to reproduce in the next generation.
6. There are no random events; the system is deterministic.

This model assumes that only sterile males are released and that females mate no 
more than once.    Countless variations on this basic simulation can be created by changing
the structure of the model and its underlying assumptions.    Select Options from the File 
Menu to change the model structure, or select Native, Release by Zone, or Release by 
Cell from the Insects Menu to alter the model's assumptions.    Use the View Menu to 
change the way the results are presented on the screen.

Click on Getting Help for information on the available help resources and how to use 
them.



Getting Help
Curaçao features a context sensitive help system which provides information about all 

aspects of the program,    To access the help system, press F1.    This will take you directly 
to the help item most appropriate for your current situation.    If no specific help item exists
you will be presented with the help index.    Selecting Index from the Help Menu will take 
you directly to the help index.

To get help on a menu command, pull down the menu and highlight the command 
using either the mouse or the arrow keys.    While the command is still highlighted (don't 
let up on the mouse button!), press F1.    The Help window will appear with the appropriate
information.

To get help while in a dialog box. press F1.    In complex dialogs such as the Native 
Insects dialog, you will be given help on the specific item which is highlighted (e.g. 
Aggregation Index).    Simpler dialogs have only one help item.

If you need more general help with the Microsoft Windows ® environment, use the 
Help Menu in either the Program Manager or File Manager window.

To learn more about the help system, press F1 while the Help window is active, or 
select Using Help from the Help window's Help Menu.



Run
Once you have decided on the appropriate options and parameters, select Run from 

the File Menu to begin execution of the simulator.    The island of Curaçao, with its initial 
insect population, will be created in the main application window.    Another window will 
appear which shows a running summary as the simulation progresses.    Each time you 
click the Generation button in the main window, another generation will be simulated.



Options
Options allows you to make changes in the structure of the model.    

 The Options dialog box uses a rotary selection control symbolized by the chasing 
arrows icon.    Click on the control to cycle through the available options.    The options are:
1. Spatial Resolution - low, medium, high
2. Order of Events - timing of release relative to mating and dispersal
3. Deterministic vs. stochastic simulation
4. Population Dynamics - density-dependent or density-independent



Spatial Resolution
 With low spatial resolution, a single, central cell constitutes one zone, and the six 

surrounding cells make up a second zone.    With medium spatial resolution, there are three
zones with 7, 12, and 18 cells, respectively.    The high spatial resolution also has three 
zones, but with 19, 42, and 66 cells.



Order of Events
The default order of events is release:mating:dispersal.    Two other orderings are 

possible, release:dispersal:mating and dispersal:release:mating.



Stochastic vs. Deterministic Model
The stochastic option generates random variates in the processes that determine the 

numbers of:
- Wild female adults
- Females that mate
- Matings that are with fertile males
- Adults that emigrate from a cell
- Eggs carried by fertile females
- Offspring that survive to adulthood
The destinations of emigrating adults are also determined randomly with the stochastic

option.



Density Dependence
Four factors in the model can be made density-dependent:
          - Probability of a female mating
          - Fecundity
          - Survival
          - Emigration rate



Log to Disk
Log to Disk allows you to keep a running log of your simulations in a text file on disk.   

This is especially useful for preparing printed reports.    If you choose Log to Disk after a 
number of generations have been simulated, all generations back to the first will be 
included in the log.



New
New allows you to begin a new simulation.    You may repeat the same problem or 

change parameters and/or options before running the new simulation.    Any parameters or 
options not changed will be the same as in the last simulation.    

Repeating the same simulation is especially useful when running the stochastic model.  
In this case, the same options and parameters can give different results simply by random 
chance.    



Open
Open allows you to open a disk file in which you have stored the options, parameters, 

and initial values for a particular simulation or the state of the program at the moment you
executed the Save As command in a previous run.    



Save As
Save As creates a Curaçao document on disk using the name and extension you 

provide.    Use of the .SIR extension is strongly recommended to distinguish Curaçao 
documents from other types of files.    If you add a line for the .SIR extension to the 
[extensions] section of your WIN.INI file, you will be able to start Curaçao simply by double 
clicking a document.

A Curaçao document contains the complete state of the simulation at the time it was 
saved.    If you save a document named STARTUP.SIR, Curaçao will load it automatically 
when you start the program.    In this way, you can override the default settings provided 
for the various parameters and options.



Exit
This selection terminates Curaçao.    The same thing may be accomplished by double 

clicking the close box in the upper left corner of the Curaçao window.



Native Insects
Native... allows you to set the initial populations of native insects in each of 3 zones

and to set the native population parameters, including the aggregation index, the 
probability of emigration, the proportion female, the eggs per female, and the 
survival to adult.



Initial Population
The island is divided into three concentric zones (only two zones with the low spatial 

resolution option).    You can set the initial population of native insects in each zone by 
entering the desired number in the appropriate box.



Aggregation Index
Knipling's original model assumed uniform dispersion of the native insects.    In Curaçao

you can create spatial variability and adjust the degree of aggregation by assigning a 
nonzero value to the aggregation index.    This parameter is actually the coefficient of 
variation (standard deviation/mean).    A value of 0.0 gives a uniform dispersion, while a 
value of 1.0 gives a severely clumped dispersion.



Probability of Emigration
This parameter sets the proportion of the population in each cell that will leave that cell

during the dispersal phase of each generation.    Individuals leaving a cell have an equal 
probability of moving to each of the six neighboring cells.    If a cell is on the boundary of 
the outermost zone, dispersing individuals leave the modelled area and disappear into the 
sea!



Proportion Female
This parameter sets the proportion of the native insect population that is female.



Eggs per Female
This parameter sets the number of eggs produced per female.    This parameter along 

with the Survival to Adult determines the normal trend of the population.



Survival to Adult
This parameter sets the proportion of eggs that survive to the adult stage.    This 

parameter along with Eggs per Female determines the normal trend of the population. 



Release by Zone/Cell
Sterile males may be released either by Zone or by Cell.    Release by Zone... allows 

you to set the initial release ratios (sterile:fertile) or initial release numbers in each of 3 
zones. Release by Cell... allows you to set the initial release ratios or initial release 
numbers cell by cell.    

The release of sterile males in each zone or cell can be by numbers of males or by the 
ratio of sterile males to fertile males.    The sterile:fertile ratio can be determined by exact 
knowledge of the native population, or by an estimate of the native population that varies 
randomly according to a normal distribution with a standard error equal to 40% of the 
mean population. 

If sterile males are being released by cell, they can be released in all cells (in which 
case the release ratios are determined cell-by-cell, according to the initial populations of 
native males in each cell), or specific cells can be marked for release of sterile males.    If 
the marked cells only option is turned on, the cells can be marked only after clicking OK 
in the Release by Cell dialog box, initiating execution by selecting Run from the File 
Menu, and then selecting Mark Cells from the Insects Menu.

The competitiveness of the released, sterile males relative to the native, fertile males
for mating success can be set to 1.0 (sterile and fertile males equally competitive) or a 
value less than 1.0. 



Marking Cells for Release
Mark Cells allows you to mark the cells in which you would like to release sterile 

insects.    This command is available only when Release by Cell has been selected and 
the button for Marked Cells Only is checked in the Release by Cell dialog box.    If this is
the case, you will be reminded by a dialog box when you choose Run to start the 
simulation.    Cells can only be marked once the simulation has been started and the island 
has been created.

To mark or unmark cells, you must choose Mark Cells from the Insects Menu.    When
you do this, the cursor will change to a cross-hair and the Generation button will 
disappear.

Cells are marked by double clicking when the cursor is on the desired cell.    Marked 
cells (those that contain circles) can be unmarked by double clicking on them.    When all 
the desired cells have been marked, select Quit Marking from the Insects Menu.    The 
cursor will then change back to the normal arrow shape, and the Generation button will 
reappear. 



Show/Hide Grid
In this model, the island of Curaçao is divided into a grid of square cells.    All of the 

simulation calculations are performed for each individual cell in each generation.    The 
Show/Hide Grid command in the View Menu allows you to choose whether or not the lines 
separating cells are drawn on the screen.    For ease of reference, the cells are assigned 
coordinates as (row, column) pairs.    Holding down the mouse button while the arrow 
cursor is over a cell will cause that cell's coordinates to be displayed.    



Population Levels
The density of the native insect population is represented on a geometric scale of 1 to 

10.    Solid green represents the lowest population density; solid yellow the highest.    
Intermediate levels are represented by intermediate shades.    The size of the population 
which will be represented as level 10 can be set in the Population Levels dialog box, as 
can the factor relating each level to the next.    

For example, by default, level 10 represents a population of 10,000,000 insects per cell
and the factor is 10.    Hence level 9 represents 1,000,000, level 8 is 100,000, and so on.



Summary Window
As you proceed with the simulation generation by generation, the Summary Window 

shows the native insect population in each zone and the number of sterile males which 
have been released.    The Show/Hide Summary command in the View Menu allows you 
to control the presence of this window.    The Summary window can also be hidden by 
double clicking the close box in the upper left corner of the window.    The summary can be 
presented as columns of numbers (Text Summary), or as a line graph which rescales 
automatically to fit the size of the window (Graphic Summary).



While Simulating...
When you have selected Run from the File Menu and the island has been created, 

some of the menu commands will be disabled to prevent inappropriate changes in options 
and parameters.    Other items will be enabled to allow you to control how the simulation 
results are displayed and to control the program itself.    The most important control at this 
point is the Generation button in the lower left corner of the window.    Clicking on this 
button will cause the simulation to progress through one more generation.    By browsing 
through the menu system and using the Help system, you can learn more about the other 
available options.
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About Curaçao
Curaçao is based on the work of Sawyer   et al.(1987)  .    The simulation has been 

refined and adapted to the Microsoft Windows ® environment (ver. 3.0 or higher) by Phil 
Arneson and Barr Ticknor, Department of Plant Pathology, Cornell University.    Curaçao 
is copyright © 1990 Cornell University; all rights reserved.    Microsoft is a registered 
trademark and Windows is a trademark of Microsoft Corporation.

Permission is hereby granted for this program to be freely copied and distributed 
subject to the following terms and conditions:
1. All such copying and distribution must be done free of charge.
2. The program and all associated materials must not be modified in any way.
3. All of the following files must be distributed together :

CURACAO.EXE - the main program
KEYHOOK.DLL - the keyhook library which supports the context sensitive help 

system.
CURACAO.HLP - the help file
CURACAO.WRI - the manual in Microsoft Windows Write format

4. If Curaçao is used in the teaching of any academic course, registration is 
required.  For each course and each semester in which Curaçao is used, a copy of the 
course registration form from the back of the manual must be completed and sent to 
the address given below before the program is used.    In addition, at the end of the 
course, or at the end of the module in which Curaçao is used, each student must be 
required to complete a copy of the Student Questionaire at the back of the manual.    
These questionaires must be returned promptly to the address below.    These 
requirements are in lieu of any other payment.

Registration forms, student questionaires, and donations in any amount to 
support the development of other programs such as this should be sent to:
Department of Plant Pathology
Cornell University
Ithaca, NY    14853
Attn: B. E. Ticknor


